Automatizando e personalizando instalações do Windows 7 com arquivo de respostas do Windows SIM

Esse post está em desenvolvimento.
Tentei seguir o tutorial nativo do WAIK, mas ele contém alguns erros (eu explico no vídeo). Mas já dá para se ter uma excelente noção de como utilizar a ferramenta.
Só fiquei devendo a explicação final de como adicionar o arquivo de respostas no WDS. Coloco já.

Update: 22 de Agosto de 2010

Bom, muitos me pediram para acertar logo isso, então aqui vai o link direto do meu FTP:
http://www.bernardes.org/projeto-waik.zip
Não está do jeito que eu quero ainda. Estava tentando seguir um tutorial que vem com o MDOP, mas ele é falho. Vou bolar outro Autounnatend.xml (com mais modificações de exemplo) e posto logo aqui.
Para quem ainda não entendeu, o Windows SIM personaliza o arquivo install.wim e te ajuda a criar um arquivo de respostas, autounattend.xml. Todo DVD, desde o vista, contém um arquivo install.wim, ele é a imagem em sí do sistema operacional (é, também não existe mais “instalação”, mesmo com o DVD o que ocorre é a aplicação de uma imagem).
Quem não tem o WDS para testar, pode usar o tutorial e testar a imagem em um DVD normal, basta usar um programa que possa editar a ISO do DVD do Windows e gravar outro com as sua versão do install.wim (dentro de sources no DVD) e o Autounnatend.xml. (dentro da raiz do DVD, ou, simplesmente espete um pendrive durante a instalação).

    Comments

    1. o video ta com problema nao roda

    2. ola
      nao esta funcionando o video

    3. ola rafael
      o video nao carrega
      aguardo

    4. Também não estou conseguindo visualizar o video.

      • Pessoal, eu sei que o vídeo não está no ar. Mas tentem fazer o download do arquivo, com o botão direito e escolha “Salvar como”.
        Esta semana estou em SP e não tenho como verificar isso!!! Uma semaninha de férias, sou filho de Deus!
        Desculpem pela demora, mas essa semana só estou concentrado em quantas voltas vou dar na montanha russa do Hopi Hari, rsrsrsrsr

        • Mesmo fazendo o Download o video não roda, o arquivo mp4 não está do diretorio especificado.
          Boas voltas na montanha russa, e assim que puder não esqueça de nós estou aguardando esse video ansiosamente.
          Valeu.

    5. Rafael bom dia?
      A respeito do video ainda não está funcionando, tem alguma previsão de quando ele vai funcionar.
      Att
      Welber Pinheiro Narciso.

    6. Muito bons os outros tutoriais, ajudaram bastante, estou aguardando a disponibilização deste que é onde estou travado a algum tempo.
      Alguma previsão de quando conseguirá publica-lo? naõ rola nem baixar, da arquivo indisponivel!
      Abs…

    7. Certo Bernardes,
      Agradeço muito se conseguir, vai agilizar a minha vida!
      vlw…

    8. Rafael
      o video ainda nao funciona
      poste ele no youtube
      aguardo e valew

    9. Testei e tambem não rolou, nem em casa e nem no trampo! tenta subir no ftp como vc tinha sugerido antes, pelo o menos download rola.
      abs…

    10. Agora deu certo, valeu pelo topico, será de grande ajuda.
      e parabens pelo blog, ja esta na aba favoritos.
      Abs…

    11. Olá Rafael,
      preciso de uma dica, estou fazendo testes com WDS, mas não consigo fazer o arquivo de resposta funcionar. Testei o arquivo a partir de uma instalação de CD, colocando ele no pen-drive durante a instalação e funcionou de boa, agora quando associo com uma imagem de instalação do Win7 nas propriedades da imagem no WDS não acontece nada, ja tentei como Autounattend.xml, Unattend.xml e outros nomes, já peguei os exemplos do tutorial da MS e nada.
      Tem algum macete??
      Vlw…

    12. Cadê o vídeo?

    13. Rafael, estou com um problema com o WDS. Estou fazendo alguns testes para começar a utilizar essa ferramenta para fazer deployment nas estações, mas algo da errado quando associo o arquivo de resposta com a imagem que quero utilizar.
      O arquivo de resposta esta configurado para fazer wipe na partição, criar uma nova e fazer toda a instalação automaticamente. Mas a instalação para na parte de configração do disco e tenho que configura-lo manualmente, apagando e criando a partição novamente e o restante da instação ele segue utilizando o arquivo de resposta sem nenhum problema.
      O estranho é que quando coloco o mesmo arquivo de resposta em um pen-drive e faço a instação a partir do CD o computador executa todo o processo de instalação sozinho.
      Já teve esse problema?
      Abs…

      • Bom,
        Vou ter que fazer um lab disso amanhã. Eu não costumo usar o WDS com arquivo de respostas. Da única vez que testei, lembro que foi tudo bem.
        Eu uso muito o WDS com imagens de windows 7 preparadas com os softwares da empresa.

        • Não sei exatamente qual era o problema, mas troquei o arquivo de boot e funcionou normalmente. Ainda estou na fase de testes, quero colocar em pratica no começo do ano e tenho muito o que fazer ainda!
          Vlw pela ajuda.

    14. Olá Rafael,
      Aqui de novo pedindo um help, consegui fazer o WDS funcionar de boa, transfiro as imagens com zero touch, mas não consigo utilizar o Multicast, temos um patio com 1200 maquinas e precisamos transmitir pelo menos para um grupo de 30 de cada vez ou mais se possivel.
      Sigo os passos de criação do Multicast e coloco para iniciar a transmissão com 2 clientes por exemplo, crio a sessão, dou boot na maquina, ela aparece na sessão multicast criada, mas não aguarda o segundo cliente, após uns 30 segundos a transferencia começa e a maquina sai da sessão.
      Já teve esse problema?
      Vlw..

    15. Rafael,
      Estou com um outro problema, consegui fazer tudo fucionar de boa, mas tem um recurso que é muito importante pra mim, pois na empresa temos um patio com mais 1000 equipamentos e é muito pratico replicar com multicast, mas não consigo utilizar o recurso, quando crio a seção de multicast e defino para que os clientes aguardem por exemplo a contagem de 10 clientes para que a transmissão inicie automaticamente para todos ao mesmo tempo.
      As estações entram na seção, aguardam uns 10 segundos, saem e começam a transmissão cada um de uma vez. com isso não posso startar muitos clientes de uma vez para não prejudicar a performance, pois fica a transmissão fica muito lenta e os clientes começam a dar erro, porque cada cliente esta em uma tranmissão diferente e não em multicast.
      Alguma sugestão??
      Abs…

    16. Cara, alguma coisa errada no meu processo…
      Minha instalação precisa ingressar o computador no domínio automaticamente.
      Fiz a formatação, instalação e personalização de uma máquina. Generalizei ela através do Sysprep.
      No servidor, instalei o WDS, criei a inicialização para capturar imagens, capturei essa imagem dessa máquina personalizada.
      Agora, estou na etapa de criar o arquivo de resposta que faça todo o resto.
      Ele funciona bem – define as linguagens, informação de região, cria o usuário local padrão, faz o particionamento do disco, tudo ok.
      Mas ao final da instalação, a maquina esta no grupo de trabalho WorkGroup. E não há Cristo que faça a máquina entrar no domínio.
      Já tentei usar o UnsecureJoin, mas não funciona. Já tentei usar as credenciais corretas, mas também não vai.
      E já conferi a opção no WDS que deve ser desmarcada para que todo cliente seja ingresso no domínio.
      Não consigo saber o que está errado e porque a máquina não ingressa no domínio sozinha.

    17. Bernardes,
      tem como vc me passar outro link para baixar… esse nao está mais funcionando.
      Obrigado pelos videos…
      Grande abraço!

    18. Rafael, já consegui criar o arquivo de resposta, porém não sei como adicioná-lo ao WDS. Você poderia me ajudar?
      Abraços!

    Deixe uma resposta

    O seu endereço de e-mail não será publicado. Campos obrigatórios são marcados com *

    © 2019 All Rights Reserved. Cooperati.