Hybrid Configuration: Usuário do Exchange Online não visualiza Free/Busy de alguns usuários On-Premise

 

 

Olá pessoal,

Recentemente tive um problema muito estranho relacionado a Free/Busy em um ambiente de Exchange Server Híbrido. Usuários que estavam no Exchange Online enxergavam a disponibilidade de apenas alguns usuários que estavam no ambiente On-Premise.

Com isto comecei o Troubleshoot analisando da seguinte forma:

 

Free/Busy

image

 

Procedimentos para tentar a resolução do problema:

-Get-OrganizationRelationiship | fl no ambiente On-Premise

-Get-OrganizationRelationiship | fl no ambiente Online

-Comparação de atributos dos usuários através do LDP.exe

-Get-FederationInformation | fl no ambiente On-Premise

-Get-FederationInformation | fl no ambiente OnLine

-Get-Mailbox –Identity <User que nao funciona> | fl

-Get-Mailbox –Identity <User que funciona> | fl

-Mover os dois usuários para a mesma Database

-Utilizar o EXTRA para analisar conectividade no CAS

Após várias análises percebi que o usuário do Exchange Online não estava conseguindo alcançar o servidor de CAS corretamente, mesmo todos os testes de Autodiscover funcionando corretamente.

Para resolver o problema basta setar o parâmetro –TargetSharingEpr.

O parâmetro TargetSharingEpr especifica a URL dos Serviços Web do Exchange de destino da organização externa. Se o parâmetro TargetSharingEpr for usado, o Exchange sempre usará essa URL para chegar ao servidor de Client Access e não usará as informações do parâmetro TargetAutoDiscoverURL para localizar o servidor de Client Access.

O comando utilizado para a correção do problema é:

Set-OrganizationRelationShip -Identity “Nome da Relação de Organização” -TargetSharingEpr https://autodiscover.empresa.com.br/EWS/Exchange.asmx

Para saber o “Identity” da Relação de Organização basta utilizar o comando Get-OrganizationRelationShip.

 

Espero que sirva para outros consultores e administradores que tenham o mesmo problema.

Até a próxima,

Diogo Heringer

clip_image001