Vídeo – Squid integrado com Antivírus

Continuando nossa série de posts sobre Proxy, vamos hoje incrementar mais ainda nosso Squid. Todo administrador já se deparou com o problema de máquinas infectadas, já bloqueou acesso a Pen-drives, já fez inúmeras solicitações para os usuários não saírem baixando qualquer coisa na internet, mas não surtiu efeito.

Vamos fazer com que nosso Proxy também trabalhe como Antivírus de arquivos da internet, combinando o Squid com o HAVP.

Como o HAVP e o Squid seus usuários correrão menos riscos ao usar a Internet.

Veja no vídeo abaixo:





Obrigado pessoal e não se esqueçam de comentar, sugerir e principalmente assinar o nosso Portal.

  • Muito bom tio Vagner,

    Eu até iria fazer um desses para o Forefront TMG, mas iria levar só 5 clics no Windows! Não seria um bom tutorial, rsrsrs

    • Zenildo Silva

      Vagner,

      A melhor coisa desse video fo a frase: “Usuarios, não dá para viver sem eles, e não dá para não ter vontade de acabar com eles”. SENSACIONAL. É melhor patentiar. kkkk.
      Brincadeiras a parte, não vou elogiar o video porque ai é chover no molhado.
      Eu já uso o squid a algum tempo, inclusive autenticando no AD, usando GPO para configurar automaticamente o proxy, etc..
      Mais tenho a seguinte duvida: Num ambiente com estações no dominio (AD), uso GPO para configurar. Mais, e por exemplo, notebooks que não estao no dominio, como fazer para “forçar” a configuração automatica de proxy?
      Já vi alguma coisa sobre WPAD, acho que é isso.
      Tem como continuar usando gpo e outra solução em conjunto para os notebooks?

      Obrigado.

      • Zenildo,

        O WPAD é uma excelente solução pra você, ele pode ser entregue via DHCP ou pelo endereço em um servidor web e serve para configurar proxy em máquinas que não estão no domínio, sem interferir nas suas GPOs.

  • Pingback: ()

  • Cara… Muito bakana o teu post, ainda não tinha visto nenhum desses seus vídeos.

    Muita qualidade mesmo.

  • Ola Vagner Fonseca, muito boa sua video aula,
    porem notei um problema no meu squid quando configurei pra rodar com o antivirus, seguindo sua aula,
    usando o usuario = usuarioteste e senha 123 que vc criou no inicio tudo funcionou maravilhas, porem depois que instalei o HAVP e adicionei as tres linhas no squid eu nao conseguia entrar mais em nenhum site, todos me retornavam acesso negado. Voltei a video aula pra ver se tinha ficado algo errado quando notei que vc ja nao mais usava o referido *usuarioteste* e sim *user1* e como sou novato no linux nao consegui proceguir, tive que desabilitar o antivirus, se voce puder me der uma dica ficaria agradecido. obrigado.

    • Anestor,

      Quando eu fiz a separação em grupos diretores, funcionarios e estagiarios eu passei a usar de user1 a user6 para fazer teste com os grupos, apenas eles são usados agora. Verifica novamente as 4 linhas que tem que ser adicionadas no arquivo para ver se não faltou algo.

      Um abraço.

  • Ola Vagner Fonseca,

    Vc tem razão, eu não tinha visto o video anterior, era somente a autenticação, agora ta rodando ***maravilha***, obrigado pela atenção.

    Grande abraço.

  • Pingback: ()

  • Michel Hespanha

    Boa tarde Vagner,

    Segui o tutorial e tudo funcionando, quando cheguei no final, e dei o comando netstat -natp, percebi que o squid nao estava rodando, isso apos adicionar as 5 linhas icp_port e tals, e dei o comando squid status, e estava como stop, dei o squid -z, me reportou as seguintes linhas de erro: FATAL: Bungled squid.conf line 9 cache_peer 127.0.0.1 parent 8080 0 no-query no-digest no-netdb-exchange default.

    e eu comentei as linhas e restartei o squid, e voltou a funcionar novamente,

    o que sera que fiz de errado?

    Abraço

    • Colocae essa linha e testa:

      cache_peer localhost parent 8080 0 no-query no-digest no-netdb-exchange default

  • Rogerio

    Bom Dia Vagner !

    Fiz de acordo com seu video porem nao consigo dar permissão mandatoria no /etc/fstab

    Filesystem not supporting mandatory locks!
    On Linux, you need to mount filesystem with “-o mand”
    Exiting..

    • Você fez no fstab com a opção mand entre as opções dentro do arquivo?